It’s “fuselage”.
It’s called like that because of it came from the word “forme fuselé” (Tapered shape) and it’s a french word mainly because we created it in 1908.
You’re welcome :-)
It’s “fuselage”.
It’s called like that because of it came from the word “forme fuselé” (Tapered shape) and it’s a french word mainly because we created it in 1908.
You’re welcome :-)
Was going to say that.
@OP:
One of the main skill a developer must have is being able to troubleshoot properly how their code behave.
Break your code in small pieces, check all of them with unitary test (formal or not) to validate their behavior then move to the next step. Never test everything in one shot or you will be overwhelmed by side effect bugs whom will distract you from the real root cause.
Being a programmer is not just coding but also testing and deploying (even locally).
That won’t avoid you being blocked by a silly mistake for hours, everybody did that at some point in their career, but that will reduce your frustration against yourself when you discover why the bug existed.
Do a pause, go walk, change the topic and the next time you look at your code, you will spot the obvious bug :-)
except if you compare it with windows 11.
My Win11 was so bad (compared to Win10) than I’ve switched to ArchLinux. I’ve won around 10~20fps without doing anything particular (and also gain some better loading time as the nvme sequential access performance was much much better under linux).
Exactly what i did. Help also to not mix work and private life by having 2 distinct VM: one with ArchLinux for Gaming/Private apps, one with win10 for work
I’ve spent some time reading this page and the associated exchanges between these people/devs. Amazing work and professional behavior. I’m impressed.
Indeed, you can achieve a better result with less verbose naming convention. And choose better variable name to make it obvious than 0 Hp is death. While i don’t like having too verbose variable name (as it impacts the readability and quick understanding of the function), i’m not against that for the function name… without going too far of course!
Best is too have proper datamodeling of the object manipulated on top of some classic basic comments. Good interface contract is also a minimum. Best is to have full datamodeling of all the services, objects, in and out interactions between them, etc.
Documentation is a mandatory piece of the code delivery (with tests being the other important part) far too much forgotten if you don’t enforce it on your teams.
I don’t see the benefit of this long naming convention…
It still allow bug to exist… like the fact that, with this code, the player can still play with 0 Hp.
Should have been better to put a “if(health <= 0)” instead of “< 0”
Bravo, very good explanation! As fun fact, i still have at work several DEC ALPHA and OpenVMS servers (some are now VM but we still have physical servers from this era managing our data) and Ctrl+C works well!
Totally useless “article”. You learn nothing, you have to navigate between poor writing with high usage of explectives. It’s like reading a 11 years-old rebel child blog.
tdrl: he use Arch linux, boomers…
Didn’t expected a “Great Teacher Onizuka” meme after all these years but yeah!