• 0 Posts
  • 8 Comments
Joined 1 year ago
cake
Cake day: June 3rd, 2023

help-circle







  • Those are just types. You shouldn’t write types in the names. It’s called Hungarian Notation, but it’s just redundant. If you need to check the type of a variable, hover over it and your IDE should tell you that temperatureThreshold is type DegreesCelsius. No need to add extra cruft. There’s also a question of how specific everything needs to be.

    It’s also especially problematic if you later refactor things. If you change units, then you have to rename every variable.

    Plus, variables shouldn’t really be tied to a specific unit. If you need to display in Fahrenheit, you ideally just pass temperatureThreshold and it converts types as needed. A Temperature type that that has degreesF() and degreesC() functions is even cleaner. Units should just be private to the type’s struct.