• 0 Posts
  • 2 Comments
Joined 1 year ago
cake
Cake day: June 11th, 2023

help-circle
  • This is technically responsive, but I think you have a fair criticism. A single rule like this would be much more maintainable:

    #content .grid-container {
    	width: 90vw;
    	min-width: 12rem;
    	max-width: 75rem;
    	padding: 2rem 0 1rem;
    }
    

    Obviously, media rules have their place, but not for something that’s consistantly a full width container like this seems to be.


  • I’m a new developer. Is that referring to page 123 of the in-house documentation? Version 12.3 of the code? I have no clue.

    You’d have to call it something like calculatePersonalIncomeTaxPerTaxCodeSection1_2_3, but I get exhausted just looking at that. There comes a point where the cognitive work of reading crazy long camel case names is more trouble than it’s worth.

    An explanation of what specification a function was written to implement is a perfectly appropriate comment. Could be improved by a direct link where possible. But it’s worth noting what that comment isn’t doing - specifying any implementation details. For that, I really can just read the code.